Configure the Water Utility Network Editor map

Once you have deployed the Water Distribution Network Editor project in your organization, you can configure the Water Distribution Editor map to meet your organization's needs. In this section, common workflows for configuring the map are outlined below.

Configure feature templates

Base feature templates are included with the Water Distribution Editor map to support editing common water utility assets. Feature templates can be used to define attributes and used in groups to add multiple features. They can also define the containment or connectivity of features that participate in a utility network. Since the feature templates included with the Water Distribution Editor map are not all-inclusive, you can configure additional templates to support the creation of assets common to your water utility.

  1. In ArcGIS Pro, open the Water Distribution Network Editor project.
  2. On the View tab, in the Windows group, click Catalog Pane Catalog Pane to open the Catalog pane.
  3. In the Catalog pane, click the Maps drop-down arrow to view maps included with the project. Double-click the Water Distribution Editor map to open it.
  4. On the Edit tab, in the Features group, click Create Create Features to open the Create Features pane.
  5. In the Create Features pane, click Manage Templates Manage Templates to open the Manage Templates pane.
  6. In the Manage Templates pane, select the layer for which you want to modify editing templates. Then create, batch create, or delete feature templates. The following table describes the types of feature templates you can create in the project:

Template typeDescriptionAdditional information

Feature

Feature templates create features from a single data source on a predefined layer. When you add feature data to your map, a feature template is automatically generated with default settings.

Create a feature template

Group

Group templates create several different features from multiple data sources on their respective layers. You create and configure them manually by referencing existing feature templates and assigning feature builders that automatically generate features based on what you create in the map using the pointer.

Create a group template

Preset

Preset templates create features from multiple data sources in a fixed pattern at an insertion point in a map using point construction tools. You create and configure them manually by selecting features in a map. Component templates are automatically generated for the selected features, and a fixed snapshot of the selected features is stored with the template.

Create a preset template

Table

Table templates generate records in related tables when you create a new feature that participates in a relationship class. When you add a table to the contents of your map, a table template is automatically generated. You can also create and configure table templates manually when certain conditions are met.

Create a table template

Table of feature template types

Author tasks

A task is a set of steps that guide you through a workflow or business process. A task can implement a best-practice workflow, improve the efficiency of a workflow, or create a series of interactive tutorial steps. For example, you can create a task item that walks mapping technicians through the process of creating a version for their edits, adding new assets, and validating topology.

  1. Open the Water Distribution Editor project if necessary.
  2. On the View tab, in the Windows group, click Tasks Tasks to open the Tasks pane.
  3. In the Tasks pane, click New Task Item to create a new task item.
  4. In the Task Designer pane, update the general properties of the task item.

    The task item author and description are optional. If you do not enter a task item name, the task item is given a default name. The task item description should provide an overview of what the tasks in your task item will achieve.

    Additionally, each time you update your task item, you can change the version number. This helps you track the version of the task item when it is shared or used on multiple machines. Entering a version number also allows your users to confirm that they are using the latest version of the task item.

  5. In the Tasks pane, click New Task New Task to create a new task in the task item.
  6. In the Task Designer pane, update the general properties of the task.
  7. In the Tasks pane, click the Open Task button next to the task you created to view the steps of the task. Click New Step New Step to create a step in the task.
  8. In the Task Designer pane, update the general properties of the step. Then, update the Actions of the task to run a command or geoprocessing tool or to direct the task user to do something.
  9. Add additional steps to the task as needed to support your workflow.
  10. Click Save Save to save your updates to the Water Distribution Editor project.

Share with your organization

Once you have configured the Water Distribution Editor to meet your organization's needs, you will need to package the project and share it to Portal for ArcGIS.

  1. On the Share tab, in the Package group, click Project Project Package to open the Package Project pane.
  2. In the Package Project pane, upload the project to an online account specifying the name, summary, and tags of the project. Also update Sharing Options to share the project with other editors in your organization.
  3. Click Analyze to ensure there are no issues with the project. If errors are encountered, fix the errors preventing the project from being packaged.
  4. Click Package to package the project and share it to Portal for ArcGIS.
Top